MG ZR Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Hi - i've fitted my new components, the woofers went in piece of cake, but i got a problem with the tweeters. They are fusion 1 inch tweeters and are too small for the factory tweeter mounting holes.

i've tried all the different combinations of fittings included, i've tried taping them up to make up the size difference, but besides looking pants, the tape goes all gooey in the sun, and i have spent this evening rescueing them from the inside of the door with a coat hanger!

Any suggestions? i'm tempted to just stick the standards back in and see how long they take to blow!!!

Help is much needed and much appreciated!!!
 

·
Registered
Joined
·
537 Posts
Hi - i've fitted my new components, the woofers went in piece of cake, but i got a problem with the tweeters. They are fusion 1 inch tweeters and are too small for the factory tweeter mounting holes.

i've tried all the different combinations of fittings included, i've tried taping them up to make up the size difference, but besides looking pants, the tape goes all gooey in the sun, and i have spent this evening rescueing them from the inside of the door with a coat hanger!

Any suggestions? i'm tempted to just stick the standards back in and see how long they take to blow!!!

Help is much needed and much appreciated!!!
had this problem with my pioneer tweeters too, i ended up glueing the original tweeter grill onto the pioneer tweeters and just using the original plastic grill things
 

·
Registered
Joined
·
5,002 Posts
break the old ones and take the outer ring of the old ones and glue it to the new ones and then try fitting them, bodge job but hay. i got new speakers and mine fitted in perfectly but then again i did spend £150 on them lol
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top