MG ZR Forums banner
1 - 20 of 32 Posts

·
Premium Member
Joined
·
31,424 Posts
Discussion Starter · #1 ·
Turns over ok.. Tries to fire up but each time i turn the ignition on the hazards come on...Feels fuel related but can't for the life of me work it out..Car was mis firing on way home but now nothing.
 

·
Pumped yer Maw!
Joined
·
1,946 Posts
the hazards coming on when the car is started usually means the batterys on its way out / dead....or so ive been told anyway? lol
 

·
Registered
Joined
·
3,147 Posts
Does it sound like this :

http://uk.youtube.com/watch?v=VH0n_-UfQsg

This was my Z a day after i bought it! Turned out to be a dodgy/ flat battery.

Could be a broken fuel pump. If it is that, stop trying to turn it over. Check for pump leaks.

Are the spark plugs broken?
Check for chipping of the plug or cracks.

ect ect........... could be even as simple as a blocked air filter but bit unlikly.
 

·
Premium Member
Joined
·
31,424 Posts
Discussion Starter · #11 ·
Does it sound like this :

http://uk.youtube.com/watch?v=VH0n_-UfQsg

This was my Z a day after i bought it! Turned out to be a dodgy/ flat battery.

Could be a broken fuel pump. If it is that, stop trying to turn it over. Check for pump leaks.

Are the spark plugs broken?
Check for chipping of the plug or cracks.

ect ect........... could be even as simple as a blocked air filter but bit unlikly.

Not battery as said earlier...Fule pump is priming..No leaks...And plugs all ok plus she getting a spark :)
:eek: nope already done it :p ...there i was offerin u a hug ... well u can stick ur hug up ur.. *"£$%*"$*% :cry:

LMFAO :D
 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top