MG ZR Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
258 Posts
Discussion Starter #1
when i had my ecu remaped the guy at chip tuning said that my plugs and the leads were worn out and i needed new ones(he did say it was my ignition but it was down 2 the leads n plugs.my car has been funny on start up sometimes).....he wanted 2 do it but i told him not 2 as i knew i could probs do it myself.he told me it was a common problem.....and he told me i would b losin power cause the plugs r fooked n they werent sparkin right n burnin the fuel proper,hence im losin power.anyhow,i wanna uprate the leads if i can so does any1 know if u can get them?or will i just have 2 put stock 1's in?n what plugs do ppl recomend?cheers in advance.
 

·
Registered
Joined
·
890 Posts
leads on the 105 are just single 2mm wires as they're really just signal, you car has coil packs above the cylinders, so the only thing you can really do is change the plugs and make sure they're the right gap. Don't go mad on the sprak plugs though, cause TBH, they aren't going to make a massive difference, but the gap will.
Steve
 

·
Registered
Joined
·
258 Posts
Discussion Starter #3
i've just been talkin 2 magnecor n they say the do replacment leads 4 the 105......they r the kv85 leads,part number 45393,or 40393.they r listed for the rover 45 1999 onwards......but he says they r the same leads.so i've ordered them anyhow(the kv85's)i phoned the guy up at chip tuning n he said i need coil extensions aswell.u cant get uprated or performance ones so i'm gonna have 2 get them from the dealer.......
 

·
Senior Member
Joined
·
989 Posts
how do ya no when u need to change ya spark plugs like ??

when can u tell if they aint firing properly ...

Yes ... im an amature haha
 

·
Registered
Joined
·
258 Posts
Discussion Starter #5
pic up will b shit(mine was)trouble startin,will start but i usually have 2 give it some throttle,MPG will up(u will get less)these were all my symptoms.i knew sumat was wrong but not sure what.it started around same time as i fitted my viper kit,so put it down 2 that.the guy at chip tuning noticed it n told me that there was a problem.i've had a look and the leeds r dirty n full off moisture so........
 

·
Registered
Joined
·
258 Posts
Discussion Starter #6
like i said ive ordered the magnecor leads and denso iridium plugs.the site i got um off do a deal for the leads n plugs.

http://www.sparkplugs.co.uk

the leads r £27-ish and the guy told me the plugs were just short of a tenner each...the best b good uns!all in with delivery it came 2 £67.93
i've been told and read that the magnecor r good leads so.

i was runnin at 122bhp b4 the ecu remap.but the guy at the place i got it done told me about the leads n plugs n said i would b lossin abit of power,so when this is sorted and with the ecu remap i'm thinkin i would b pushin on 140bhp......135bhp at least......we shall c.....
 
1 - 6 of 6 Posts
Top