MG ZR Forums banner

1 - 20 of 76 Posts

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #1 ·
oki, maybey some of you remember I had problems with the tappets on my zed a few weeks ago. It all started after a service was done on my car. I then took it back and the guy flushed the oil and put new oil (fully synthetic for rover) it was running great for about 2 weeks, but now this noise is coming back!!!! its not constant though! what can it be?:w00t:
 

·
Registered
Joined
·
5,785 Posts
Its a common fault on cars bought from auctions lol. Honestly, they can be a bit tappety, does it quiten down when its warm?
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #3 ·
Its a common fault on cars bought from auctions lol. Honestly, they can be a bit tappety, does it quiten down when its warm?
thats the silliest thing ive ever heard! the car has been running fine untill it had been serviced a few weeks later!! the noise aint as bad as it was when the tappets had blocked. but obviously something aint righ somewhere
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #4 ·
Its a common fault on cars bought from auctions lol. Honestly, they can be a bit tappety, does it quiten down when its warm?
its the other way round really! I just been for a drive now and when I came back, the noise was worse. but its hard to keep track and try work out if the noise is when its cold/warm.
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #7 ·
About the oil, when he serviced it, he admitted to using semi synthetic and maybey that’s what caused the tappets. He sorted the tappets and put fully synthetic specially for rovers! Ive just been on the phone with him now, told him that this noise is coming back, and I said shall I but castrol oil and he can flush the old and but the castrol in, his reply was ‘ohh not, it must not be the oil as this oil I used was specially for rovers’, hes gonna have a look at it Saturday for me anyway. But im feeling rather peed off tbh
 

·
Dirty user
Joined
·
31,429 Posts
About the oil, when he serviced it, he admitted to using semi synthetic and maybey that’s what caused the tappets. He sorted the tappets and put fully synthetic specially for rovers! Ive just been on the phone with him now, told him that this noise is coming back, and I said shall I but castrol oil and he can flush the old and but the castrol in, his reply was ‘ohh not, it must not be the oil as this oil I used was specially for rovers’, hes gonna have a look at it Saturday for me anyway. But im feeling rather peed off tbh
Wait and see what he says :)
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #9 ·
ye, i know! but I was hoping maybey someone here has had the same problems! and im just fed up!! lol
 

·
Registered
Joined
·
1,451 Posts
exactly the same thing has happened to me, it was serviced by the garage just before i bought it, took it back saturday under warantee so ill see what they say later :) but everyone suggested the same sort of thing for mine, tappets, wrong oil, maybe warn cam but that would make a noise all the time.
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #15 ·
exactly the same thing has happened to me, it was serviced by the garage just before i bought it, took it back saturday under warantee so ill see what they say later :) but everyone suggested the same sort of thing for mine, tappets, wrong oil, maybe warn cam but that would make a noise all the time.
didnt it make that noise before the service? maybey we have shoit mechanics!! lol but I think that this mechanic I take mine to has realised that this is his co*k up!mayey thats why hes cheap! :snap:
 

·
Registered
Joined
·
1,451 Posts
well, i went for a test drive and it was fine, the guy claims he didnt start it earlier in the day for me, so it started fine. I bought it, then they serviced it and MOT'd it, went back it seemed fine, got it home after first night the bugger was rattling :/ gonna ring them a little later on so ill report back on what they say.
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #18 ·
No one ever tell you . . .

you buy cheap you buy twice
hes only started to charge me less since this problem!! i did pay over £100 for a full service! when he sorted my tappets, he flushed the oil and put new oil, all for £20 so i thought that was cheap! and he put brake pads for £30.
 

·
Banned
Joined
·
3,811 Posts
Discussion Starter · #19 ·
well, i went for a test drive and it was fine, the guy claims he didnt start it earlier in the day for me, so it started fine. I bought it, then they serviced it and MOT'd it, went back it seemed fine, got it home after first night the bugger was rattling :/ gonna ring them a little later on so ill report back on what they say.
is yours a 105?
 
1 - 20 of 76 Posts
Top