MG ZR Forums banner
1 - 6 of 6 Posts

·
Rusty Hole......
Joined
·
1,475 Posts
Discussion Starter · #1 ·
i've hit a problem last night. was on my way from Peterborough when i lost all power in the GSi, all came to a halt and it wouldnt restart. checked over the cables/HT lead etc see if something silly like that had caused it and tried restarting, yet again it wouldnt start.

i took the oil cap off and had the creamy mess of what i'd of put down to a blown head gasket. anyway spent the whole of today tring things after finding we had compression on all cylinders. we tried my spare ECU and Air flow meters, but found that it was flooding the engine with petrol. i have tried a spare fuel Rail to but nothing seems to have worked.

Any ideas guys. i havnt done a proper compression test but it has tired to fire, it just seems that it floods before it has chance to fire.
 

·
Registered
Joined
·
12,564 Posts
sounds like hgf with the creamy mess in the oil.
 

·
Rusty Hole......
Joined
·
1,475 Posts
Discussion Starter · #3 ·
thats my thoughts but there isnt any mess on the dip stick.
 

·
Registered
Joined
·
3,916 Posts
the mayo in the oil cap is normal for the 8v..if it was hg failure there would be a loss of comp on 1 or 2 cyls.and water on the oil.see when you pull the dipstick out.
have a look at the cam belt,take the disi cap off and see if the cam turns the rotor arm. (had a few in with snaped cams)
 

·
Registered
Joined
·
28 Posts
I'd check the cam belt if i were you mate, sounds like all your doing is pushing fuel in, which might be caused by valves being stuck open, I think on that engin there is a black plastic case on the left side of the engin, remove that, should be in there. Might be wrong, hope I am if you get me. Good luck.
 
1 - 6 of 6 Posts
Top