MG ZR Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Anyone got similar problems, i took the car to the garage and i think there was a loose nut or something on the manifold so they fixed it and all was good, a few weeks later its exactly the same :( feels like there is no petrol in it and it judders low down in the revs range.
 

·
Formerly Trophynovabasher
Joined
·
3,051 Posts
does it suddenly burst into life and give you whiplash?

if so, search for my thread under "engines" folder, something like "car hesitating under acceleration"
mine was the lambda sensor, but could also be coils, plugs, leads etc.
 

·
Is Constantly Horny
Joined
·
5,063 Posts
if the manifold was leaking co2 you would hear it coming out so go have a listen, if the car feels like its not right could be a number of things coils missfire under/over fueling dodgy lambda etc
 

·
Registered
Joined
·
8,474 Posts
heres the bad news, the k series juddering low in the revs is quite a well known thing (strangely quite often after having the head gasket done) mine was the same, it would hesitate and splutter its tits off until 3000 rpm and then it would kick me in the back. it only did this until it was warm. the bad news bit is the fact that as of yet nobody has found a definitive solution, there have been instances where its just been the plugs, and ones where it was the lamba sensor. Personally iv tried both of those with mine, along with the cam sensor, tbh i tried pretty much everything except for the crank sensor. there was a guy on .org who had the same problem for 3.5 years up to present and still hasnt sorted it. :S

fortunately i no longer have to worry about mine as i blew it up as punishment...
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top