MG ZR Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
3,732 Posts
Discussion Starter · #1 ·
Hi guys, had my car a week and have done 150 miles effortlessely in it! Today I gave the entire engine the once over with Auto Glym Engine de-greaser (being carefull not to get it on the electrics)

However, I checked the engine oil and from what i could see on the dipstick - the lower green part of the dipstick looked very dry, I then toped up the oil and waited a few moments and checked it again - the green part showed some oil on it now. 10 mins later it looked very dry.

My previous car had a honda engine which clearly indicated the oil level. Im finding the k - series a mystery.

Last full serivce was a mere 6000 miles ago (with invoice proving oil was changed) can anyone suggest what I should do? :thankyou:
 

·
Registered
Joined
·
6,440 Posts
The new Mr Andaynes
 

·
Premium Member
Joined
·
3,732 Posts
Discussion Starter · #5 ·
Cheers peeps, my dipstick does not have the red or blue indicators and also it just looks very dry rather than giving a accurate indication of how much oil is in the engine.

Im finding it a bit hard to explain!!
 

·
Premium Member
Joined
·
31,429 Posts
Cheers peeps, my dipstick does not have the red or blue indicators and also it just looks very dry rather than giving a accurate indication of how much oil is in the engine.

Im finding it a bit hard to explain!!
Lol none of them have the colour its just high lighted to show max and min :)
 
1 - 7 of 7 Posts
Top