MG ZR Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all you derv lovers!

I have a query regarding the way my car drives. When cold and starting of in first gear (ie around 1000-1200rpm)and rising the clutch my car would shake as if there is very minor clutch shudder. I had my clutch replaced at 5000 miles due to the plates breaking up! That feeling was totally different. What I have noticed as well is when cold and you are sitting in neutral and you rev the engine to around 1200-1400 rpm and hold those revs, the car shakes. If you lift the bonnet you can see the engine shake. Presumably this is what I feel when driving of in 1st. However, when the car is warmed up it is usually fine. I have had the ECU checked and a new steady bar fitted to the buttom of the engine with no avail. Any others have this problem/ normality issue withy their TD 115 engines?

Regards and keep suckin' diesel!!!

:up:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I have had all engines mounts checked and even the buttom one replaced. Is your car be totally smooth when starting off? I understand a diesel is less refined than petrol and alot of vibration in the car exists. Before I bought mine i remember the demonstrator being vibtratey because of the diesel engine.
 

·
Registered
Joined
·
1,358 Posts
zr+td115 said:
Hello all you derv lovers!

I have a query regarding the way my car drives. When cold and starting of in first gear (ie around 1000-1200rpm)and rising the clutch my car would shake as if there is very minor clutch shudder. I had my clutch replaced at 5000 miles due to the plates breaking up! That feeling was totally different. What I have noticed as well is when cold and you are sitting in neutral and you rev the engine to around 1200-1400 rpm and hold those revs, the car shakes. If you lift the bonnet you can see the engine shake. Presumably this is what I feel when driving of in 1st. However, when the car is warmed up it is usually fine. I have had the ECU checked and a new steady bar fitted to the buttom of the engine with no avail. Any others have this problem/ normality issue withy their TD 115 engines?

Regards and keep suckin' diesel!!!

:up:

Ok ..Mine's really different..smoooooth as silk .....but I DO KNOW whats causing this ...........

I had a pug 406 HDI (company car) did the very same thing ....chugged & coughed fer the first 10/15 miles ..(Til it got warm) then it was ok

THE PROBLEM :-.........you have a partially blocked injector, Prob on either No 1 or No3 Pot ................

THE SOLUTION........Change ALL THE INJECTOR'S AS A SET !!!!!.....DO NOT change just one ...you'll make it worse !!!!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Cheers guys for the suggestions. My dealer is contacting MG to see if they have a solution. It appears to be intermitent, somedays worse than others. In my own mind I think is an ECU issue as mine has had the same software update installed 2 times in 3 months. Had them check it out in Dec for engine shake and a new boot lock in Feb and they noticed it required an update because they had it plugged into computer. I have had no ECU warning lights on my dash and no fault codes have been logged! Who knows what the gremlin is. Other than that the TD 115 really does shift its ass and is amazing fun to drive!

:wallb:
 

·
Registered
Joined
·
1,144 Posts
well mine went in fo some warrantly work - I said nothing about the engine - they checked over the whole car and updated the ecu she goes like a dream smooth. I love my dealer :up:
 
1 - 7 of 7 Posts
Top