MG ZR Forums banner
1 - 7 of 7 Posts

·
Senior Member
Joined
·
1,232 Posts
Discussion Starter · #1 ·
Just jumped in the car to go out for the night... turned the key...
......and nothing

All the electrics turn on, radio etc, but the car just clicks. :x: :wallb:
 

·
*
Joined
·
2,039 Posts
Could be a faulty starter motor.............give it a little tap with a hammer, might do the job...............and i'm not joking :up: :up:
 

·
Registered
Joined
·
72 Posts
Starter motor connections could be lose, try cleaning them. The Spark plug leads may also be giving a bad connection. Try spraying WD40 on them. I had the same problem with my car a few months back, when it was off the road for long periods of time, changed the startor motor but that wasn't it. Cleaned the connections and this fix'd my problem. Sorry I cant be more technical as I dont know what else it could be.

HTH
Ian
 

·
Registered
Joined
·
81 Posts
had this a few weeks back it was a bad connection on the battery+ terminal my fauilt thoe had it on and off when fitting some ice ;)
 

·
Registered
Joined
·
316 Posts
Had EXACTLY the same problem on mine 2 weeks ago. Tapped the starter motor and the electric casing next to it with a spanner and started fine. Took it to the dealer and they said there was a loose cable in the electric assembly of the drive motor. Been fine ever since!

Oh - and they washed and hoovered the car for me as well !! :up:
 

·
Senior Member
Joined
·
1,232 Posts
Discussion Starter · #7 ·
Mine just randomly started half an hour later.. seems fine now.. But the exhaust keeps wheezing..
 
1 - 7 of 7 Posts
Top