MG ZR Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
I had the heater on in my car the other day.

When i got out the car (engine still running and heater still on) there was a squealing noise,it stops when I turn the heater off! any ideas? :-k
 

·
Senior Member
Joined
·
2,585 Posts
nah might be your alternator belt slightly wet or maybe needing changed ( i suggested this because the heater fan thing drains quite a bit of power i think )
 

·
Registered
Joined
·
7,532 Posts
Agreed, but then alternator belts will normally slip and squeal on engine accelleration as well.

The fan on the heater dosent pull that much current. The biggest drain is the heater rear window, so see if you get the squeal by turning that on instead. If you do then probably the belt if not then look for something else like heater motor bearings
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #7 ·
Cleared the vents below windscreen and problem seems to have sorted itself out, only a few leaves in there so would it have been that?

It could just be an intermitent problem? :-s
 

·
Senior Member
Joined
·
989 Posts
ive just had my alternator fixed like ...


it used to sqweel ... and the sound used to go up and down with acceleration. I got it sorted yesterday and as i drove out the belt on it slipped ( or summit like that ) and made one hell of a sqweelin noise ... but i took it back and he tightened it up. sorted

btw bearing for the alternator ( if thats what it is ) cost about 40 quid
 
1 - 8 of 8 Posts
Top