MG ZR Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
my zeds only 10 months old and two weeks ago the cam shaft went i was only going about 15 mph got it all done on the warranty but when i spoke to the mechanic he asked me had it been chipped not by me i said as ive only had the car 3 months surley the garage would know if it was or not woud,nt they anyway all done now they cahnged the oil and filters and ive got to take it for first service in march you thought they would have stamped my book now but i suppose i will just have to pay for it in march :wallb:
 

·
Registered
Joined
·
96 Posts
They should be able to tell if it's chipped by plugging it into T4 and checking.
 

·
Registered
Joined
·
4,039 Posts
Was it the camshaft that broke, or the cambelt, not heard of the actual shaft breaking.

Steve
 

·
Registered
Joined
·
2,340 Posts
Manufacturing defect if the camshaft itself, even if it had been chipped it would last longer. Cambelt shouldn't break for such a low amount of use. I don't trust main dealers as most of them around me don't know the difference between a spark plug and a glow plug(as was proved on a mates pug 206 deisel)
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #7 ·
no he said it was the cam shaft and some sort of pump went as well he seemed pretty clued up thoughit sounded like a london taxi and i could have walked faster.
 

·
Registered
Joined
·
2,340 Posts
If a pump went, what will haave happened will be the cam belt will have gone as this is attached to the water pump for the radiator, you replace both cam belt and cam shaft at the same time. It is really difficult to break the cam shaft as it is inside the engine and not attached directly to any pump.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #9 ·
i dont know mate but still should not have gone on 6000 milesalso the fuel gauge did not work they sorted it but put a knew mile ometer which read 0 so ive only done 600 miles now and they dont seem to bothered just said o well we can put it in your service book if you like but they never did just hope i dont get done for clocking it.
 

·
Registered
Joined
·
3,916 Posts
I think MR C has had a similar thing with his a few months back....on the derv the inj pump is run of the back of the cam.has its own belt to drive it.

ive had a few cams snap in the past on differnt engines in the past...
 
1 - 12 of 12 Posts
Top