MG ZR Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4,936 Posts
yeah this happened to mine the catch wont move squirt the locking bit on the boot lid with WD40 and work it abit sorted mine out!
 

·
sugarmom
Joined
·
784 Posts
Have you tried slamming it really hard? I find that works for me! :clown:
 

·
Proud ZR 160 Mk1 Owner
Joined
·
620 Posts
You need to open the boot take the black plastic cover off to reveal the locking system and spray wd 40 onto the locking system and keep pressing the button to work it in... Had the same problem last year.
 

·
:(
Joined
·
1,896 Posts
this was the problem i had when brought the car, me and my dad completely ripped out the motor and mech and stripped the mech apart and scraped all the rust of and rebuilt it. Before we put it back together we packed it with grease. Now it works fine and has done for a whole year lol.
 

·
Registered
Joined
·
2,487 Posts
Mine also broke a few months back. The garage said the mechanism had siezed. So they took the cover off and greased it all, its fine now.
 

·
I'm comin hoommmeee again
Joined
·
1,175 Posts
Pull the plastic cover off the boot part. Look at it from behind and you can easily see the catch mechanism. Use a screwdriver to press the catch up and see how much movement there is in the lock that springs across.

The mechanism is awful. It's too flexible and I think the spring has a habit of stretching.

Get some WD40 and operate it a few times whilst you watch. It may fix the problem or just offer a temporary solution.

If you keep slamming your boot hard it will make it worse !!
 

·
Registered
Joined
·
121 Posts
ahh poo, mines broke too and have been just slamming it shut for the last couple of months,i took it to the mg garage by mine aswell and he didnt seem to know what to do,he messed around with it a bit and it did work better for a while but its really bad now, will i need to replace it do you think?
 

·
Registered
Joined
·
2,260 Posts
Discussion Starter · #13 ·
will have a look at it tomorrow and report back

tied it down with string in the mean time
 

·
I'm comin hoommmeee again
Joined
·
1,175 Posts
The problem with it is the arm that locks the catch. The rest of it is fine. It's a rediculous set-up. the arm just goes where it wants. Any grime gets into it and it just stops.

I wouldn't of thought a new one would cost that much though, or be a particularly hard job to do !
 

·
Registered
Joined
·
2,260 Posts
Discussion Starter · #15 ·
well it wont click into place

you push it down and wont click into place

will take the cover of inside tomorrow and see if it jamed


only problem its that is mislocks so when u lock it it wont lock right and the boot light stays on too.

on the dash that is
 
1 - 15 of 15 Posts
Top