MG ZR Forums banner
1 - 20 of 24 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I own a 03 plate Mg Zr express 2.0TD. Today during a long drive (200miles) I filled up with diesel and after approx. 10 mins the exhaust started to bellow out black smoke when the accelerator was open more than 50%. If I floored the accelerator big thick black smoke would bellow out constantly until pressure was released on the pedal.

The car had no warning lights or increase in temperature.

Any ideas lads?

(btw van/car has done 90k miles)

Cheers
 

·
Registered
Joined
·
730 Posts
It really does sound like a boost leak. The throttle position determines how much boost pressure is delivered, i.e. full throttle means 100% boost. If the leak is not visually obvious, open up the throttle to get the system under pressure and this should help find out where the lead is. I seriously doubt that you will need a new turbo. If you need the long intercooler hose, I have a new one in the shed that I can sell you.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #12 ·
Well I opened up the bonnet today and the hose has melted. The surface of the intercooler hose is very sticky. Where two hoses have contacted eachother the rubber has literally melted.

Difficult to describe but the rubber has a liquid sticky surface which can be scratched off.

Cant be radiator hose as it has not lost water and not overheating so I presume its the intercooler hose. Tho there is no sign of penetration and leakage.
 

·
Banned
Joined
·
1,220 Posts
Well I opened up the bonnet today and the hose has melted. The surface of the intercooler hose is very sticky. Where two hoses have contacted eachother the rubber has literally melted.

Difficult to describe but the rubber has a liquid sticky surface which can be scratched off.

Cant be radiator hose as it has not lost water and not overheating so I presume its the intercooler hose. Tho there is no sign of penetration and leakage.
The melted hose is probably your problem area, get that replaced, and you should be fine i reckon.

Have you checked for splits in either of the intercooler hoses?

Cheers
Dave
 

·
I'm comin hoommmeee again
Joined
·
1,175 Posts
Right, My DV pipe split on the way up the M1, que black smoke pouring out. A garage sorted me a temp replacement, reconnected and it's fine ! Because too much air (I think) was going into the engine, it was causing the car to overfuel. The difference in performance is noticeablke too !
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #15 ·
Well I did a 120 mile back home last nite. Its not healthy in the slightest - it has worsened.

Basically when in 5th and you set the accelerator to 50% the car revs up to max it can go at that throttle position. But instead of keeping constant it lurchs forward and back. Almost as if the car cant keep constant revs. It ever has to be accelerating or de-accelerating nothing in between. With each lurch there the engine gets louder and puff of black smoke flows from the back!

Kinda funny when ever people tailgated me on the motorway I just gave em a window full of black smoke!

The performance has indeed been severly effected.

Luckily got me spare car out the garage because I think my zed is finally dying!
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top