MG ZR Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
583 Posts
Discussion Starter · #1 ·
Right, fitted an amp couple weeks back, all works fine and great on the radio, but when I press CD, the music only plays through the front speakers (non amp) and the amp light goes off!!!

Yet it all works fine when it's on the radio! All wires checked (not a problem there as it works on radio)

Relly weird, hopefully someone could help or throw me n the right direction

Cheers :super:
 

·
Registered
Joined
·
182 Posts
have u tested the amp turn on remote?? I have seen it before that some units turn the remote off once CD is connected as some companies belive that the power anternor was no longer need when CD selected and then the remote turned off

Best thing to do is use a volt meter or run a bit of cable from the battery to the amp as a constant remote feed, even if u park another car behind ur zed and use the others cars battery (im thinking cut down the lenght of cable reqired to test)

let us know how u get on
 

·
Fake Bans FTW!!!
Joined
·
1,482 Posts
if all dosent work try this

run remote feed from your battery to your amp just to test, dont leave it on because the amp wont turn off and will drain the battery
 

·
Registered
Joined
·
5,209 Posts
Almost certainly a problem with your headunit :yes:

An amplifier wont just turn itself off if the radio is selected, unless the headunit has told it to via the remote cable :no:

As has been mentioned, id check the options on the headunit to try and clear up the problem :)
 

·
Fake Bans FTW!!!
Joined
·
1,482 Posts
run the remote cable to the battery and put a switch on it!
 

·
Registered
Joined
·
4,808 Posts
have u tested the amp turn on remote?? I have seen it before that some units turn the remote off once CD is connected as some companies belive that the power anternor was no longer need when CD selected and then the remote turned off

Best thing to do is use a volt meter or run a bit of cable from the battery to the amp as a constant remote feed, even if u park another car behind ur zed and use the others cars battery (im thinking cut down the lenght of cable reqired to test)

let us know how u get on
That is something I would have never have thought of :)

sounds like this is the best possibility of the lot, nice one!
 

·
Registered
Joined
·
583 Posts
Discussion Starter · #12 ·
Cheers guys, used a voltmeter froom live to remote and it was kicking out 12v which was odd, so I knew it was something to do with me headunit.

pressing random buttons after a while and pressed the TA button, and it came on!! Something so simple!

Cheers everyone.
 
1 - 12 of 12 Posts
Top