wont start - theMGZR.co.uk :: MG ZR forum
Go Back   theMGZR.co.uk :: MG ZR forum > General > General MG ZR Discussion
Register FAQ Calendar Mark Forums Read Advertise

Reply
 
LinkBack Thread Tools Display Modes
Old 10-01-2017, 13:49   #1 (permalink)
*Newbie* Handle with care
 

Posts: 13
Location: Shropshire
Drives: mgzr 1.4
Join Date: May 2014
iTrader: 0 (0%)
Thanks: 0
Thanked 0 Times in 0 Posts
animalwildchild is on a distinguished road
wont start

fitted new engine using all the old stuff off my original engine( wires injectors all the bolt on bits) everything appears to be in the right place, ive checked fuel up to the injectors, and if i spray easy start in it fires but fuel isnt getting to the engine any clues as to why as this rail all worked on the old engine and as i said all ive done is replace the engine.
animalwildchild is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-01-2017, 17:21   #2 (permalink)
Senior Member
 

Posts: 1,323
Location: Lincolnshire
Join Date: Sep 2004
iTrader: 0 (0%)
Thanks: 1
Thanked 66 Times in 62 Posts
Man in the Car will become famous soon enoughMan in the Car will become famous soon enough
Not entirely sure.

Have you tried resetting the fuel cut-off switch (big rubber plunger type thing mounted on the rear bulkhead near between the brake master cylinder and the fuel filter).

Might be a timing issue - check that the orientation of the dowels in the v-shaped slot in the cam pulleys is correct, and the pulleys are correctly set with both EX marks to the rear when the bottom pulley is lined up with the timing mark above it.

Have you kept the ECU from the original engine? If so, it should work as before, but if you have fitted a different ECU, it will need security matching to the security ECU (the two units share a common code to enable disarming opf the immobiliser).
Man in the Car is offline   Reply With Quote
Old 10-01-2017, 19:33   #3 (permalink)
 JOHNDQ
Senior Member
 
JOHNDQ's Avatar
 

Posts: 466
Location: Bedfordshire
Drives: Evo 7 RS Sprint 2.0
Join Date: Mar 2012
iTrader: 0 (0%)
Thanks: 11
Thanked 13 Times in 13 Posts
JOHNDQ is on a distinguished road
Are you sure crankshaft sensor is plugged in?
JOHNDQ is offline   Reply With Quote
 
Old 10-01-2017, 19:41   #4 (permalink)
*Newbie* Handle with care
 

Posts: 13
Location: Shropshire
Drives: mgzr 1.4
Join Date: May 2014
iTrader: 0 (0%)
Threadstarter
Thanks: 0
Thanked 0 Times in 0 Posts
animalwildchild is on a distinguished road
yep all correct ..... found out the problem blockage in fuel line to injector rail no all firing
thank you for you input peoples
animalwildchild is offline   Reply With Quote
Old 10-01-2017, 23:38   #5 (permalink)
Senior Member
 

Posts: 1,323
Location: Lincolnshire
Join Date: Sep 2004
iTrader: 0 (0%)
Thanks: 1
Thanked 66 Times in 62 Posts
Man in the Car will become famous soon enoughMan in the Car will become famous soon enough
That's good that you have found the problem. Good also that it was a fairly simple fix
Man in the Car is offline   Reply With Quote
Old 30-01-2017, 17:53   #6 (permalink)
*Newbie* Handle with care
 

Posts: 13
Location: Shropshire
Drives: mgzr 1.4
Join Date: May 2014
iTrader: 0 (0%)
Threadstarter
Thanks: 0
Thanked 0 Times in 0 Posts
animalwildchild is on a distinguished road
sucks

well thats a ruddy bind bought an engine with supposedly a uprated headgasket, drove 14 miles and the bloody gaskets gone again last time i trust a garage to do what they say trouble is had a 60 day warrenty and im on day 70
animalwildchild is offline   Reply With Quote
Old 30-01-2017, 18:05   #7 (permalink)
 JOHNDQ
Senior Member
 
JOHNDQ's Avatar
 

Posts: 466
Location: Bedfordshire
Drives: Evo 7 RS Sprint 2.0
Join Date: Mar 2012
iTrader: 0 (0%)
Thanks: 11
Thanked 13 Times in 13 Posts
JOHNDQ is on a distinguished road
Trouble is mate the MLS gasket is only and good if liners are correct and the cheap kits seem to be rubbish. Ive always used Payen for MLS never had any trouble with it
JOHNDQ is offline   Reply With Quote
Old 25-02-2017, 09:52   #8 (permalink)
*Newbie* Handle with care
 

Posts: 13
Location: Shropshire
Drives: mgzr 1.4
Join Date: May 2014
iTrader: 0 (0%)
Threadstarter
Thanks: 0
Thanked 0 Times in 0 Posts
animalwildchild is on a distinguished road
broken engine

well spoke to trading standards, citzens advice and gmb solicitors all say the same engine was not of merchantable quality and not fit for purpose. come monday the letters go off and start the ball rolling down the legal road
animalwildchild is offline   Reply With Quote
Old 13-04-2017, 07:18   #9 (permalink)
*Newbie* Handle with care
 

Posts: 13
Location: Shropshire
Drives: mgzr 1.4
Join Date: May 2014
iTrader: 0 (0%)
Threadstarter
Thanks: 0
Thanked 0 Times in 0 Posts
animalwildchild is on a distinguished road
quick tip
if you buy anything offline over 100 quid pay for it with a credit card then if the item is not up to scratch you can ask the credit card company for a section 75 chargeback, this is where THEY get the money back from the seller....
it doesnt have to be 100 quid i did it with only 50

Last edited by animalwildchild; 20-04-2017 at 15:53.
animalwildchild is offline   Reply With Quote
Old 13-04-2017, 14:26   #10 (permalink)
 JOHNDQ
Senior Member
 
JOHNDQ's Avatar
 

Posts: 466
Location: Bedfordshire
Drives: Evo 7 RS Sprint 2.0
Join Date: Mar 2012
iTrader: 0 (0%)
Thanks: 11
Thanked 13 Times in 13 Posts
JOHNDQ is on a distinguished road
Yeah good advice I never get anything unless its on my credit card when just pay it off straight away when like you say if it goes wrong got a bit of come back
JOHNDQ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
car sometimes wont start electrical immobilizer Soobom Electricals 8 26-11-2013 13:44
Car wont start - Possible electric problem? RThomas Electricals 6 29-01-2013 15:51
Engine start problem. Please pass views! Rameen Problems and Miscellaneous (Sponsored by Parts Gateway) 2 16-10-2011 16:58
Car won't start! Lauren Problems and Miscellaneous (Sponsored by Parts Gateway) 24 19-09-2011 22:36
Start Problem millerc Problems and Miscellaneous (Sponsored by Parts Gateway) 24 15-02-2009 12:45


All times are GMT +1. The time now is 09:01.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©2004 - 2014 theMGZR.co.uk Ltd 06371623

The theMGZR.co.uk logo is registered with the UK Copyright Service: 285179

 

Garage vBulletin Plugins by Drive Thru Online, Inc.